Back to overview
Resolved

Some services are down

Aug 4, 2026 at 6:39pm UTC
Affected services
Database Service
Web & Mail Service
Virtualabs.cloud

Resolved
Aug 4, 2026 at 7:06pm UTC

Our Upstream provider managed to find the issue and has put a fix in place. we are still monitoring the situation on our end but can confirm recoverery of our web service.

Updated
Aug 4, 2026 at 6:43pm UTC

Our Upstream provider is currently experiencing DNS related issues. We migrated the issue by bypassing our domain based service routing temporarily and are awaiting an status update from them.

Created
Aug 4, 2026 at 6:39pm UTC

We are aware of issues with some services and are working closely with our upstream provider to find and resolve the cause of issue.